Back to overview
Downtime

Production is down

Mar 20, 2026 at 8:14am UTC
Affected services
Person Profile Data
Person Profile Match
Email Finder from URL
Email Finder from Data
Person Posts
Person Comments
Person Reactions
Person Post
Post Comments
Post Reactions
Post Reposts
Company Profile Data
Company Search
Company Posts
Company Post
Post Comments
Post Reactions
Post Reposts

Resolved
Mar 20, 2026 at 8:55am UTC

Services are progressively coming back online. We have successfully switched to a new proxy provider. The propagation is currently underway, and we expect everything to be fully back to normal by 10:00 AM (Paris time). Thank you for your patience.

Created
Mar 20, 2026 at 8:14am UTC

Our production environment has been down since 2:20 AM (Paris time) this morning. We are currently experiencing an issue with our proxy provider. We are actively working on switching to a new provider to resolve the situation. We do not have an ETA for resolution yet and will keep you updated as soon as we have more information. We apologize for the inconvenience.